fbpx

Netwatch: Monitoring Perangkat dengan Google Chat

monitoring mikrotik

Tutorial ini menunjukkan cara mengonfigurasi notifikasi MikroTik melalui webhook Google Chat. Dengan cara ini, Anda akan menerima pemberitahuan penting tentang MikroTik langsung di space Google Chat pada Gmail Anda.

Netwatch: Sebuah Alat Pemantauan Jaringan yang Kuat

Netwatch merupakan salah satu fitur MikroTik yang sangat bermanfaat untuk monitoring jaringan. Tool ini memungkinkan Anda untuk memantau perangkat di jaringan Anda secara real-time dan menerima notifikasi jika terjadi masalah.

Cara Kerja Netwatch:

Netwatch bekerja dengan cara mengirimkan pesan ICMP ke perangkat yang ingin dipantau. Jika perangkat tidak merespon dalam waktu yang ditentukan, Netwatch akan menganggap perangkat tersebut down. Anda dapat menentukan apa yang harus dilakukan Netwatch ketika perangkat down, seperti:

  • Menulis pesan di log router.
  • Mengirimkan email notifikasi.
  • Menjalankan script.

 

Persiapan:

  1. Akun Gmail: Anda memerlukan akun Gmail untuk menggunakan Google Chat.
  2. MikroTik RouterOS: Pastikan router MikroTik Anda sudah terhubung ke internet.
  3. Netwatch: Konfigurasikan Netwatch pada router MikroTik Anda.

 

Langkah-langkah:

1. Memahami Webhook:

  • Webhook adalah mekanisme yang memungkinkan aplikasi berkomunikasi satu sama lain secara real-time.
  • Ketika suatu peristiwa terjadi di satu aplikasi, webhook akan mengirimkan pemberitahuan ke aplikasi lain.
  • Pemberitahuan ini biasanya berupa HTTP POST request yang berisi data tentang peristiwa tersebut.

 

2. Membuat Webhook Google Chat:

  • Buka Google Chat di Gmail.
  • Buat ruang baru atau pilih ruang yang sudah ada.
  • Klik Apps & Integrations
  • Klik Add Webhook.
  • Beri nama webhooks Anda, mis. “Alert Manager”.
  • Salin URL webhook.

 

Untuk langkah detailnya bisa dilihat pada gambar di bawah ini.

  •  

Note :

  • Ubah webhook URL pada script dibawah sesuai dengan URL yang sudah di copy dari Webhooks pada Google Chat sebelumnya.
  • Ubah local message, sesuai dengan pesan yang ingin anda tampilkan sebagai notifikasi nantinya.

Langkah 3: Konfigurasi Script 

  • Buka Winbox dan masuk ke router MikroTik Anda.
  • Buka System > Scripts.
  • Buat 2 script “Router-Edge-Up” (atau gunakan nama yang relevan).
  • Centang Don’t Require Permissions.
  • Tempelkan (paste) script berikut ini pada kotak script, ganti nilai placeholder yang ada:

Note :

  • Ubah webhook URL pada script dibawah sesuai dengan URL yang sudah di copy dari Webhooks pada Google Chat sebelumnya.
  • Ubah local message, sesuai dengan pesan yang ingin anda tampilkan sebagai notifikasi nantinya.

Script Up

				
					:local webhookURL "https://chat.googleapis.com/v1/spaces/AAAAM6mvT3k/messages?key=AIzaSyDdI0hCZtE6vySjMm-WEfRq3CPzqKqqsHI&stoken=ymnnAVdw-9boAebsHVOddd9I2ilMsvrfd6AZ-YKCalY"
:local strdate [system clock get date];
:local strtime [system clock get time];
:local message "Router Edge is UP at $strtime on $strdate"

/tool fetch url=$webhookURL http-method=post http-header-field="Content-Type: application/json" http-data="{\"text\":\"$message\"}"
				
			

Script Down

				
					:local webhookURL "https://chat.googleapis.com/v1/spaces/AAAAM6mvT3k/messages?key=AIzaSyDdI0hCZtE6vySjMm-WEfRq3CPzqKqqsHI&token=ymnnAVdw-9bossAebsHVOddd9I2ilMsvrfd6AZ-YKCalY"
:local strdate [system clock get date];
:local strtime [system clock get time];
:local message "Router Edge is Down at $strtime on $strdate"

/tool fetch url=$webhookURL http-method=post http-header-field="Content-Type: application/json" http-data="{\"text\":\"$message\"}"
				
			
monitoring mikrotik dengan netwatch

Konfigurasi via CLI

				
					/system script
add dont-require-permissions=yes name=Router-Edge-Up owner=reza policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":local webhookURL \"https://chat.googl\
    eapis.com/v1/spaces/AAAAM6mvT3k/messages\?key=AIzaSyDdI0hCZtE6vySjMm-WEfRq3CPzqKqqsHI&token=ymnnAVdw-9boAebsHVOddd9I2ilMsvrfd6AZ-YKCalY\"\r\
    \n:local strdate [system clock get date];\r\
    \n:local strtime [system clock get time];\r\
    \n:local message \"Router Edge is UP at \$strtime on \$strdate\"\r\
    \n\r\
    \n/tool fetch url=\$webhookURL http-method=post http-header-field=\"Content-Type: application/json\" http-data=\"{\\\"text\\\":\\\"\$message\\\"}\""
add dont-require-permissions=yes name=Router-Edge-Down owner=reza policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":local webhookURL \"https://chat.goo\
    gleapis.com/v1/spaces/AAAAM6mvT3k/messages\?key=AIzaSyDdI0hCZtE6vySjMm-WEfRq3CPzqKqqsHI&token=ymnnAVdw-9boAebsHVOddd9I2ilMsvrfd6AZ-YKCalY\"\r\
    \n:local strdate [system clock get date];\r\
    \n:local strtime [system clock get time];\r\
    \n:local message \"Router Edge is Down at \$strtime on \$strdate\"\r\
    \n\r\
    \n/tool fetch url=\$webhookURL http-method=post http-header-field=\"Content-Type: application/json\" http-data=\"{\\\"text\\\":\\\"\$message\\\"}\""
				
			

Langkah 4: Konfigurasi Netwatch 

  • Buka Winbox dan masuk ke router MikroTik Anda.
  • Buka Tools > Netwatch.
  • Buat Rule baru gunakan nama yang relevan.
  • Ikuti konfigurasi pada gambar berikut dan klik Apply.

Konfigurasi via CLI

				
					/tool netwatch add disabled=no down-script="/system script run Router-Edge-Down" host=43.x.x.3 http-codes="" interval=1m test-script="" timeout=1m type=icmp up-script=\
    "/system script run Router-Edge-Up"
				
			

Note :

  • Ubah host dengan IP Address yang ingin dimonitor.
  • Pilih type icmp, karena kita ingin melakukan monitoring menggunakan protokol icmp.
  • Pada tab Up dan Down isi dengan script yang ingin dijalankan tadi, pastikan nama script sesuai dengan yang dibuat sebelumnya.

Pengujian

Konfigurasi tersebut memungkinkan pengambilan informasi dari perangkat yang dipantau. Fleksibilitas tinggi dalam tindakan juga dimungkinkan dengan penggunaan scripting.

Fitur Netwatch hanya tersedia pada perangkat yang menggunakan sistem operasi Router OS.

notifikasi google chat

Di era digital ini, efisiensi dan produktivitas adalah kunci utama kesuksesan bisnis. nusa.id cloud menawarkan solusi terintegrasi untuk membantu Anda mencapai tujuan tersebut.

Nikmati koneksi internet yang stabil, cepat, dan aman dengan layanan internet dedicated dari nusa.id cloud. Lupakan koneksi internet yang lambat dan tidak stabil yang menghambat kinerja tim Anda.

Tingkatkan kolaborasi dan berbagi dokumen dengan mudah menggunakan Google Workspace. Google Workspace menyediakan berbagai tools terintegrasi yang memungkinkan tim Anda bekerja sama dengan lebih efektif dan efisien.

nusa.id cloud merupakan solusi terbaik untuk meningkatkan efisiensi dan produktivitas bisnis Anda. Hubungi kami untuk informasi lebih lanjut dengan klik disini.

Reza Haikal Barus

Reza Haikal Barus

Cloud Specialist

Experienced network, cloud, and systems engineer with over 4 years of experience in the technology industry. Possesses a broad range of technical skills and the ability to work independently and as part of a team. Committed to providing high-quality service and innovative solutions to meet customer needs.

Share Artikel :

Blog Terkait

Netwatch: Monitoring Perangkat dengan Google Chat

Netwatch: Monitoring Perangkat dengan Google Chat

Tutorial ini menunjukkan cara mengonfigurasi notifikasi MikroTik melalui webhook Google Chat. Dengan

Cara Mengamankan Router MikroTik dengan Port Knocking

Cara Mengamankan Router MikroTik dengan Port Knocking

Port knocking adalah metode keamanan yang menjaga port layanan sensitif seperti SSH

Cara Membuat Signature di Gmail Google Workspace

Cara Membuat Signature di Gmail Google Workspace

Signature atau tanda tangan di email merupakan bagian penting untuk menunjukkan identitas